[Udpcast] updcast packet capture issue

Chris Healy cphealy at gmail.com
Sun Oct 6 01:34:29 CEST 2013


No, it's a wired network with a known flaw that leads to temporary packet
storms of up to a second or so.  (We are working on addressing this network
flaw, but it seems to have exposed a vulnerability within this application.)


On Sat, Oct 5, 2013 at 4:27 PM, Jayen <jayenashar at gmail.com> wrote:

> is it over Wi-Fi? There may be retransmissions, but they haven't caused me
> any issues.
> On Oct 6, 2013 10:06 AM, "Chris Healy" <cphealy at gmail.com> wrote:
>
>> Jayen,
>>
>> Thank you.  You were correct.  I no longer have this problem.  I also
>> deduced that there is a sequence number in the multicast frame.
>>
>> I'm digging into this utility as I currently have a scenario where I get
>> a bunch of duplicate frames hitting the udp-receiver (network issue, not
>> application issue) and the application does not gracefully handle it.  I
>> figured that the application did not have a sequence number.  As it does,
>> there must be some other problem.  More to come.
>>
>> Chris
>>
>>
>> On Sat, Oct 5, 2013 at 3:55 PM, Jayen <jayenashar at gmail.com> wrote:
>>
>>> I believe wireshark is trying to decode it as a different protocol which
>>> encapsulates IP in UDP.  Try disabling it.
>>> On Oct 6, 2013 6:02 AM, "Chris Healy" <cphealy at gmail.com> wrote:
>>>
>>>>  Alain,
>>>>
>>>> I'm trying to perform a packet capture of the data transmitted by
>>>> udp-sender using Wireshark and am running into the exact same problem
>>>> encountered by Lance 8 years ago.  (posting listed below.)
>>>>
>>>> What information can I provide to help debug this issue?
>>>>
>>>> Also, can you tell me if the multicast data sent includes a sequence
>>>> number and does the receiver have the ability to filter out duplicate
>>>> multicast frames?
>>>>
>>>> Regards,
>>>>
>>>> Chris
>>>>
>>>>
>>>>
>>>> On Mon 8/15/2005 10:25 AM, Alain Knaff wrote:
>>>> >*Try upgrading to a newer version of ethereal.*>**>*I just tried it
>>>> here: version 0.10.9 has the problem, but 0.10.12*>*works fine.*>**>*Or use
>>>> tcpdump...*
>>>>
>>>> I have used the lattest version of udpcast (udpcast-20050226.tar.gz)
>>>> as well as used ethereal version 0.10.12 and
>>>> I still get the "Bogus IP header length (0, must be at least 20)" I
>>>> will continue to try this on different Platforms with different
>>>> network switches and see what I get.
>>>>
>>>> -Lance
>>>> _______________________________________________
>>>> Udpcast mailing list
>>>> Udpcast at udpcast.linux.lu
>>>> https://www.udpcast.linux.lu/cgi-bin/mailman/listinfo/udpcast
>>>>
>>>
>>



More information about the Udpcast mailing list