[Udpcast] Network card Error

Darin MacLachlan dmaclachlan at hatsize.com
Tue Sep 23 23:36:17 CEST 2008


strace file	
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: udpsendererror.txt
URL: <http://www.udpcast.linux.lu/pipermail/udpcast/attachments/20080923/7f9f8df4/attachment.txt>
-------------- next part --------------




On 23-Sep-08, at 3:12 PM, Darin MacLachlan wrote:

ifconfig for eth3
eth3      Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.9.254  Bcast:192.168.9.255  Mask: 
255.255.255.0
          inet6 addr: fe80::21c:c4ff:fea7:f6ea/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:260 (260.0 b)  TX bytes:810 (810.0 b)
          Interrupt:90 Memory:fa000000-fa011100

eth3:0    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.0.254  Bcast:192.168.0.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:1    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:2    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.2.254  Bcast:192.168.2.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:3    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.3.254  Bcast:192.168.3.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:4    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.4.254  Bcast:192.168.4.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:5    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.5.254  Bcast:192.168.5.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:6    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.6.254  Bcast:192.168.6.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:7    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.7.254  Bcast:192.168.7.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100

eth3:8    Link encap:Ethernet  HWaddr 00:1C:C4:A7:F6:EA
          inet addr:192.168.8.254  Bcast:192.168.8.255  Mask: 
255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:90 Memory:fa000000-fa011100


On 23-Sep-08, at 3:04 PM, Darin MacLachlan wrote:

the network card has 192.168.9.254 associated to it,
it also has 9 virtual IP as well 192.168.0.254 thru 192.168.8.254.

I will try the strace option.



On 23-Sep-08, at 3:01 PM, Alain Knaff wrote:

Darin MacLachlan wrote:
> This was working and now it has stopped.
>
> Have a UDPcast server running on a HP DL360G5 with 4 NICS.  One
> connected to an internal infrastructure (eth2) and another connected
> to a dedicated switch with the client systems on the same switch  
> (eth3).
>
> When i run the UDPcast send or receive, using the following command:
> udp-sender -f /home/base.udpc --interface eth3 --point-to-point -- 
> full-
> duplex --max-bitrate 600m --nokbd --portbase=9922 --min-receivers 1   
> --
> rexmit-hello-interval 5000 --max-wait 300
>
> I get the following error message:
> Udp-sender 2007-03-23
> No suitable network interface found
> The following interfaces are available:
> 	lo	127.0.0.1
> 	eth2	10.46.0.251
> 	eth2:1	10.46.0.1
>
> Interestingly, an ifconfig show eth3 as a valid network adapter, but
> the udp-sender does not see the device.  This was working last week,
> and nothing has changed on the server
>
> I have tried everything, restarting DHCP, removing the interface and
> adding again.  Rebooted the server, restarted the network stack
> manually.  nothing seems to help.
>
> Using SUSE linux 10 as the base server OS.

You can only use a network card if an address is associated to it. Is
this the case? If so, which address does it have?

Could you also try running udp-sender under strace and send me the  
output?

Regards,

Alain






More information about the Udpcast mailing list