[Udpcast] Problem Multicasting Dell GX620s

Jon Miller jmiller7 at gmail.com
Wed Jan 10 18:22:16 CET 2007


I decided to try this program on a lab of 25 GX620s with SATA drives and
broadcom 57xx gigabit NICs.  I'm not sure why, but when I start a group of
machines the transfer process goes along at a fast pace (~75Mb).  However,
the process always seems to fail at different places during the transfer,
usually at about 800MB to 1.3GB of data.  Sometimes it will recover and
start going again, but usually it just stops and all the clients are
dropped.  I used udp-sender.exe on a Windows machine to transfer a GZIP'd
image created with G4U.  I know the image is good, because I routinely use
it to unicast single PCs.  On the target machines, I used the cast-o-matic
tool and selected all the SATA and NIC modules with Automatic detection.
The machines get an IP address and /dev/sda is detected  Also, I verified
IGMP snooping is enabled on the switch.

I have tried limiting the --max-bitrate to 40M.  I'm running in 100Mbit mode
--half-duplex (that's how the Summit 400 switch is setup).  I've tried using
the option on cast-o-matic to force IGMPv2 mode, because I'm not sure if our
switch could be the issue.  I also tried the udp-sender program from Ubuntu
(was the version from the default repositories.. might be old).  It had the
same problem as the Win32 version.  Although, the console had a lot more
errors than the windows version... I would get streams of Timeout
notAnswered notReady, etc messages in the console when the process would
halt.  I've also tried setting the SATA mode in the BIOS to Combination.

Anyone encountered this problem before or have a suggestion?  I'd really
like to use this program, because it seems perfect for my purposes (imaging
labs).


Thanks for any help or advise,
Jonathan Miller
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.udpcast.linux.lu/pipermail/udpcast/attachments/20070110/1bfbc924/attachment.html>


More information about the Udpcast mailing list