[Udpcast] pxe undi network driver

Alain Knaff alain.knaff at lll.lu
Sat Dec 6 11:39:32 CET 2003

begin  Friday 05 December 2003 18:44, Eric Becker quote:
> Just to try and troubleshoot, I tried merging /lib/ls-2.3.2.so from my
> pc to /lib/ld-linux.so.2 in my initrd image.
> ./makeImage -k /usr/src/linux-2.4.22/arch/i386/boot/bzImage -c
> /tftpboot/udpcast/images/udpcd.img -i /tftpboot/udpcast/initrd --bzip -m
> bcm5700 --merge /lib/ld-linux.so.2=/lib/ld-2.3.2.so
> Then I cd to /lib and do an ls, and the only thing that is there is the
> modules dir again.  I tried one more thing.  I tried merging
> /lib/ls-2.3.2.so from my pc to the root dir /ld-linux.so.2 in my initrd
> image.

Oops, I forgot: the /lib directory is a special case, because it needs
to be written to (changed) by the embedded system, and this would not
be possible on the romfs itself.

Because of this initrd mounts an empty tmpfs at this space, and
populates it from what it finds in /mod/lib

Thus, just prepend /mod to every lib file, and it should be ok:

 ./makeImage -k /usr/src/linux-2.4.22/arch/i386/boot/bzImage -c \
 /tftpboot/udpcast/images/udpcd.img -i /tftpboot/udpcast/initrd --bzip -m \
 bcm5700 --merge /mod/lib/ld-linux.so.2=/lib/ld-2.3.2.so


More information about the Udpcast mailing list